I suggest you ...

Language selector

Hi,

is there a way to switch languages in LC? I don't seem to be able to find it if there is.

Interestingly enough the mails I receive from LC are actually held in German while the website is all in English.

Thanks for your help,
/a

6 votes
Vote
Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)
You have left! (?) (thinking…)
andreas shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →
completed  ·  AdminIpek (Chief Satisfaction Officer, lifecake) responded  · 

Hello, thank you for this feedback.

We are happy to announce that we support many languages on Lifecake – such as English, French, German, Italian, Polish, Spanish, Turkish.. All you need to do is to change your device’s language settings.

For the Apps, please do so from the device’s settings. For the website, please change your browser’s language.

Hope this helps.

Have a great day!
The Lifecake Team

4 comments

Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)
Submitting...
  • Pia commented  ·   ·  Flag as inappropriate

    Seems issue is still not solved Post was from a year ago and I still cannot change language. Can you help?? Otherwise I cannot use it

  • Sue commented  ·   ·  Flag as inappropriate

    One more request to know if there is a way to change this. It is in English on my phone, but defaults to German on my computer. It's not the end of the world, but I'd prefer to be viewing it in English, and I can't find any way to change it.

  • Kim commented  ·   ·  Flag as inappropriate

    Hello, has this been fixed yet! I have the app in German too but am sharing with relatives in Australia and they are also getting emails on German? Thanks

General

Feedback and Knowledge Base